Performance related errors on sitemap and url scans
Incident Report for Osano
Resolved
Scanning issues have been resolved. The root cause of the degraded performance was due to out of date dependencies and memory management. We have updated our dependencies and refactored the scanning code to have improved error handling and memory management.
Posted Dec 22, 2020 - 17:30 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 18, 2020 - 10:52 CST
Update
The issues contributing to degraded performance of both the URL and sitemap scanning processes have been addressed. Any recent failures due to these issues are being reprocessed.
Posted Dec 17, 2020 - 10:22 CST
Identified
An issue was identified with Osano's real-time and periodic scans resulting in inconsistent performance. This issue is isolated to sitemap and url scans and does not impact the related consent manager configuration that the scan is associated with.
Posted Dec 14, 2020 - 09:19 CST
This incident affected: Application Infrastructure (URL & Sitemap Scanning).