my.osano.com failing to load due to database performance issues. Osano's engineering is actively investigating the root cause and mitigation options. Customers may experience issues logging in.

Incident Report for Osano

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 16:02 CDT

Monitoring

We've identified the root cause and have implemented a fix. We will continue to monitor.
Posted Oct 21, 2025 - 15:47 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 21, 2025 - 15:38 CDT

Investigating

We are currently investigating this issue.
Posted Oct 21, 2025 - 15:18 CDT
This incident affected: Platform (Customer Authentication, Web User Interface).