DSAR submissions are currently failing
Incident Report for Osano
Postmortem

As part of our standard security practices, Osano implements continuous key rotations executed on a regular schedule. That key rotation failed to generate new credentials for the email sending service which supports data subject access requests. This caused emails to data subject access requests to be delayed. We fixed the root cause and verified that the delayed emails were sent. Customers who were impacted by this outage have been contacted by our customer success team.

Posted May 11, 2021 - 17:01 CDT

Resolved
This incident has been resolved. DSAR forms are successfully submitting
Posted May 10, 2021 - 15:22 CDT
Update
We are continuing to investigate this issue.
Posted May 10, 2021 - 15:08 CDT
Investigating
We currently investigating an issue where DSAR submissions are failing for end-users.
Posted May 10, 2021 - 15:05 CDT
This incident affected: Platform (Data Subject Access Request (Public)).