Reporting Dashboard Performance Degradation

Incident Report for Osano

Resolved

The issue affecting our reporting dashboard has been fully resolved. All systems are now operating normally, and data is loading as expected.
Posted Mar 19, 2026 - 22:39 CDT

Investigating

We’re currently experiencing degraded performance with our reporting dashboard. Some users may notice slow load times or incomplete data. Our team is actively investigating and working to restore full service as quickly as possible. We’ll share updates here as we learn more. Thank you for your patience.
Posted Mar 19, 2026 - 17:11 CDT